Our Valued Sponsor
OpinionsConsumer ReviewsGuides and How TosCoffeeGeek ReviewsResourcesForums
Espresso: Espresso Machines
Giotto Classic - issues with
Italian Coffee
Italian coffee beans, grinds and pods from Kimbo, LavAzza, Miscela d'Oro & Bristot. Qty. discounts!
www.espressozone.com
 
Not Logged in: Log In to Postlog in
New Topics updated topics   New Posts new posts   Unanswered Posts new unanswered  
Search Discussion Board search   Discussion Board FAQ faq   Signup sign up  
Discussions > Espresso > Machines > Giotto Classic -...  
view previous topic | view next topic | view all topics
Author Messages
maple_ridge_newbie
Senior Member


Joined: 15 Dec 2013
Posts: 2
Location: Vancouver BC
Expertise: Just starting

Espresso: giotto classic
Grinder: ECM
Posted Sun Dec 22, 2013, 4:17pm
Subject: Giotto Classic - issues with
 

The pump makes the noise of pumping and water is hot when dispensed through the steamer and hot water wands but can't get no espresso happening. I haven't used the machine for several years (I bought it used from the original owner - he supplied me with receipts of past repairs and I had it tuned up by a technician after which it crapped out). The gage started at 2.5 then it moved to 3 then back again to 2.5. Hopefully the picture shows it. What's up with the machine? Oh another thing, when I turned it on and tried it I couldn't get the pump to stop - I had to turn the machine off to do so.

Thanks in advance for your insight.

PS. Can you recommend a technician/repair/service in the lower mainland. Please not in Richmond BC, Canada - it's too far to drive and I had taken it to a shop there, but it took a month to get it back.

PSS. Now nothing comes out - no steam, no hot water as it did when I first tried (moments ago). The group head is hot. Pump keeps making the noise of pumping when switched on and this is without me pulling levers/knobs.

maple_ridge_newbie: Photo1 (16).jpg
(Click for larger image)
back to top
 View Profile Link to this post
calblacksmith
Moderator
calblacksmith
Joined: 25 Nov 2007
Posts: 7,479
Location: Riverside, Ca, U.S.A.
Expertise: I live coffee

Espresso: ECM Vene. A1, La Cimbali M32
Grinder: Azkoyen Capriccio, Major
Vac Pot: 40s era Silex
Drip: Msl. Com. brewers
Roaster: gave it a try, decided no
Posted Sun Dec 22, 2013, 5:22pm
Subject: Re: Giotto Classic - issues with
 

Just taking a wild guess it sounds like thbere are several issues. It sounds like the p stat and the 3 way valve and possibly the fill system. When they sit for a while, electric problems crop up and that sounds like what is going on.

 
In real life, my name is
Wayne P.
Anything I post is personal opinion and is only worth as much as anyone else's personal opinion. YMMV!

Feed the newbs, starve the trolls and above all enjoy what you drink!
back to top
 View Profile Visit website Link to this post
CSME9
Senior Member
CSME9
Joined: 26 Feb 2004
Posts: 272
Location: West Texas
Expertise: I live coffee

Espresso: Isomac Tea, Rancilio Silvia,...
Grinder: Rancilio Rocky
Drip: Moka Pot
Roaster: BBQ Roaster
Posted Sun Dec 22, 2013, 6:01pm
Subject: Re: Giotto Classic - issues with
 

maple_ridge_newbie Said:

The pump makes the noise of pumping and water is hot when dispensed through the steamer and hot water wands but can't get no espresso happening. I haven't used the machine for several years (I bought it used from the original owner - he supplied me with receipts of past repairs and I had it tuned up by a technician after which it crapped out). The gage started at 2.5 then it moved to 3 then back again to 2.5. Hopefully the picture shows it. What's up with the machine? Oh another thing, when I turned it on and tried it I couldn't get the pump to stop - I had to turn the machine off to do so.

Thanks in advance for your insight.

PS. Can you recommend a technician/repair/service in the lower mainland. Please not in Richmond BC, Canada - it's too far to drive and I had taken it to a shop there, but it took a month to get it back.

PSS. Now nothing comes out - no steam, no hot water as it did when I first tried (moments ago). The group head is hot. Pump keeps making the noise of pumping when switched on and this is without me pulling levers/knobs.

Posted December 22, 2013 link

Maybe the pump needs to be primed using a turkey baster, it can happen when machines loose there prime-I had to do it on a new machine for 20 minutes before pump would pump water, disconnect the inlet line to the pump attach baster & pump water into pump while pump is on.
back to top
 View Profile Link to this post
frcn
Senior Member
frcn
Joined: 23 Dec 2001
Posts: 3,287
Location: Northern California
Expertise: Professional

Espresso: Vibiemme Domobar Double
Grinder: Mazzer Kony, Baratza...
Vac Pot: Hario, 2 Cory pots, 1 Cory...
Drip: Behmor Brazen, Bunn A10 mod...
Roaster: computer controlled Hottop,...
Posted Sun Dec 22, 2013, 6:04pm
Subject: Re: Giotto Classic - issues with
 

For an E-61 HX machine with these symptoms, as Wayne stated, these sounds like more then one problem. Here are a few possibilities:

PUMP NOT STOPPING:
- bad or clogged or stuck pump
- bad or stuck or dirty solenoid valve

Other causes could include:
-  bad brew switch (check to see if plunger is stuck)
-  bad control box
-  any number of electrical connections could be corroded
-  scaled or disconnected water level sensor

NO WATER THROUGH GROUP
- bad or stuck or dirty brew solenoid
- plugged gicleur

Because you are now getting no water or steam, the machine should not be used further until checked by an experienced espresso machine repair person. if you do keep turning the machine on you take the risk of burning out the heating element.

 
Visit My Website
www.EspressoMyEspresso.com
back to top
 View Profile Visit website Link to this post
view previous topic | view next topic | view all topics
Discussions > Espresso > Machines > Giotto Classic -...  
New Topics updated topics   New Posts new posts   Unanswered Posts new unanswered     Search Discussion Board search   Discussion Board FAQ faq   Signup sign up  
Not Logged in: Log In to Postlog in
Discussions Quick Jump:
Symbols: New Posts= New Posts since your last visit      No New Posts= No New Posts since last visit     Go to most recent post= Newest post
Forum Rules:
No profanity, illegal acts or personal attacks will be tolerated in these discussion boards.
No commercial posting of any nature will be tolerated; only private sales by private individuals, in the "Buy and Sell" forum.
No SEO style postings will be tolerated. SEO related posts will result in immediate ban from CoffeeGeek.
No cross posting allowed - do not post your topic to more than one forum, nor repost a topic to the same forum.
Who Can Read The Forum? Anyone can read posts in these discussion boards.
Who Can Post New Topics? Any registered CoffeeGeek member can post new topics.
Who Can Post Replies? Any registered CoffeeGeek member can post replies.
Can Photos be posted? Anyone can post photos in their new topics or replies.
Who can change or delete posts? Any CoffeeGeek member can edit their own posts. Only moderators can delete posts.
Probationary Period: If you are a new signup for CoffeeGeek, you cannot promote, endorse, criticise or otherwise post an unsolicited endorsement for any company, product or service in your first five postings.
Saeco Espresso Machines
Large selection in-stock, includes Free Gifts and Free Shipping!
www.espressozone.com
Home | Opinions | Consumer Reviews | Guides & How Tos | CoffeeGeek Reviews | Resources | Forums | Contact Us
CoffeeGeek.com, CoffeeGeek, and Coffee Geek, along with all associated content & images are copyright ©2000-2014 by Mark Prince, all rights reserved, unless otherwise indicated. Content, code, and images may not be reused without permission. Usage of this website signifies agreement with our Terms and Conditions. (0.33416891098)
Privacy Policy | Copyright Info | Terms and Conditions | CoffeeGeek Advertisers | RSS | Find us on Google+